This is another stunning example of goofy marketspeak double-talk names being slapped on things that don't need them; likely to make them sound more important than they are.
Simple system object methods, are now magically "high order functions"? BARF.
They're methods... whoopedee-huffing-doo. They don’t need some pointless new name that would make a good Carlin joke. Shell shock… battle fatigue… operational exhaustion… post-traumatic stress disorder; and the humanity is stripped right out of it.
But what can one expect from the folks who are embracing the painfully cryptic arrow function trash, and methods involving it in a way that introduces callback overhead for nothing. Though at least you didn’t talk about Array.forEach, which in 90%+ of usage cases is utter and complete incompetent trash!
Just take your card stacked increment. Map is probably slower, and it's certainly not clearer, though failing to optimize for length likely isn't helping. The use of direct assignment instead of retaining the data source being a wonderful card stack LIE to try and fake map being cleaner/clearer… and the use of let misses a scope opportunity if it were in a function namespace. (further reducing overhead, which is why I’m not a fan of let or const)
These pointless, fancy -- and often incorrect-- terms for the simplest of constructs certainly doesn't help matters. As I’ve said many places many, many times it genuinely feels like people are now just creating new names for things that don’t even need names, for the sole purpose of CONFUSING beginners and old-timers alike to maintain this oddball L33t status of people who — to be brutally frank — probably shouldn’t be coding in the first place.